Can't download receipts from Monta Hub or Monta Charge

Incident Report for Monta

Resolved

This incident has been resolved.
Posted May 18, 2026 - 10:12 UTC

Investigating

It currently isn't possible to download receipts from Monta Hub or Monta Charge. It'll result in an error.

We're investigating the issue.
Posted May 18, 2026 - 09:24 UTC
This incident affected: Monta Hub - Web Portal.