Price Groups tab is not accessible from Hub

Incident Report for Monta

Resolved

This incident has been resolved.
Posted Feb 19, 2026 - 17:19 UTC

Identified

We've identified the issue and are working on a fix.
Posted Feb 19, 2026 - 15:29 UTC

Investigating

We're currently investigating an issue where Users will encounter that Price Groups management is unaccessible from the Hub
Posted Feb 19, 2026 - 15:01 UTC
This incident affected: Monta Hub - Web Portal.