Team details not reachable in Hub

Incident Report for Monta

Resolved

Some users experienced errors when loading the team details page. The issue has been identified and resolved.
Posted Feb 04, 2026 - 01:38 UTC

Identified

Some users experience errors when loading the team details page. The issue has been identified and a fix is being implemented.
Posted Feb 04, 2026 - 01:24 UTC
This incident affected: Monta Hub - Web Portal.