Withdrawal Requests Currently Failing
Incident Report for Monta
Resolved
The incident has been resolved and we are back at processing withdraw transactions again
Posted Jun 07, 2024 - 13:19 UTC
Investigating
We're investigating an issue with our partner for withdrawals for which withdrawal requests are failing. It should be safe to retry withdrawals once we have resolved the issue.
Posted Jun 06, 2024 - 10:51 UTC
This incident affected: Wallet.