Withdrawals & Deposits Temporarily Disabled

Incident Report for Monta

Resolved

Withdrawals & Deposits are back live as per usual.
Posted May 25, 2023 - 07:16 UTC

Update

Correction: Withdrawals are still disabled until further notice, but deposits are available again. We are very sorry for the inconvenience.
Posted May 24, 2023 - 14:16 UTC

Monitoring

Deposits & Withdrawals are activated again.
Posted May 24, 2023 - 08:27 UTC

Investigating

We have temporarily disabled withdrawals and deposits to investigate an issue.
Posted May 23, 2023 - 13:51 UTC
This incident affected: Wallet.