Users cannot delete their car integrations

Incident Report for Monta

Resolved

This incident has been resolved.
Posted Nov 30, 2025 - 14:47 UTC

Investigating

We are currently experiencing an issue where users are unable to delete car integrations. Our team has identified the root cause and is actively working on a fix.

We expect to have this resolved later today or on Monday.
Thank you for your patience.
Posted Nov 28, 2025 - 09:15 UTC
This incident affected: Car Integrations.