Customer Support Backlog
Incident Report for Monta
Resolved
This incident has been resolved.
Posted Nov 11, 2022 - 18:05 UTC
Investigating
We are experiencing an extraordinarily busy period in our support channels which can result in delays and long waiting times for both chat, email and phone.

We are working through the queues as fast as we can, and count on your patience and understanding in this busy period.

Thank you and please accept our apologies for potential delays or inconveniences.
Posted Oct 28, 2022 - 09:14 UTC
This incident affected: Customer Service.