Some users unable to login to Hub
Incident Report for Monta
Resolved
This incident has been resolved.
Posted Nov 12, 2024 - 18:58 UTC
Investigating
We are currently experiencing an issue where some users are unable to log into the Hub.

Our team is investigating and working to resolve the problem as quickly as possible.

There is no need to contact Support; we will update the Status Page once this is resolved.

Thank you for your patience.
Posted Nov 08, 2024 - 13:41 UTC
This incident affected: Monta Hub - Web Portal.