Navigating to a Price Group in Hub freezes the page

Incident Report for Monta

Resolved

The issue has been resolved.
Posted Mar 02, 2026 - 09:41 UTC

Investigating

We are currently investigating a issues that causes the Hub to freeze when you navigate to a Price Group's details.
Posted Mar 02, 2026 - 09:01 UTC
This incident affected: Monta Hub - Web Portal.