Exports on Web Portal
Incident Report for Monta
Resolved
This incident has been resolved.
Posted Sep 22, 2022 - 11:56 UTC
Investigating
We are currently experiencing an issue with exporting data from our Monta Web Portal. We are working on a fix.
Posted Sep 19, 2022 - 13:36 UTC
This incident affected: Monta Web Portal.