Customer Support - Coverage
Incident Report for Monta
Resolved
This incident has been resolved.
Posted May 22, 2023 - 10:33 UTC
Investigating
The majority of our 2nd and 3rd Line Customer Support Team will be at a workshop retreat from Monday 15th until Friday 20th of May.

We will therefore have less coverage than usual for escalated cases but we will still have a few agents present to assist and monitor queues.

First line support and coverage will remain unaffected.

Thank you for your extra patience during this team 🙏
Posted May 12, 2023 - 12:20 UTC
This incident affected: Customer Service.