Intermittent access issues with Monta Hub

Incident Report for Monta

Resolved

This incident has been resolved.
Posted Mar 12, 2026 - 15:10 UTC

Investigating

We continue to receive sporadic reports of access issues. If you're still affected, please try clearing your browser's cookies and cache, then perform a hard refresh (Mac: CMD+Shift+R / Windows: Ctrl+F5).
Posted Mar 12, 2026 - 09:11 UTC
This incident affected: Monta Hub - Web Portal.