Issues with Google API

Incident Report for Monta

Resolved

This incident has been resolved.
Posted Dec 18, 2025 - 11:12 UTC

Update

We are continuing to investigate this issue.
Posted Dec 18, 2025 - 10:31 UTC

Investigating

We are currently seeing issues integrating against Google, this might impact things like location lookup and maps. We are currently investigating
Posted Dec 18, 2025 - 10:27 UTC
This incident affected: Monta Charge - App.