We are currently investigating an issue with the platform

Incident Report for Monta

Resolved

This incident has been resolved
Posted Jun 19, 2025 - 12:22 UTC

Investigating

We are currently investigating an issue affecting the platform. Some users may experience degraded performance or limited functionality across certain services.

Our engineering team is working to identify the root cause and restore full service as quickly as possible. We will share updates as we learn more.

Thank you for your patience.
Posted Jun 19, 2025 - 12:15 UTC
This incident affected: General availability.