Service disruption affecting login and app functionality

Incident Report for Monta

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 20, 2026 - 09:07 UTC

Investigating

We are currently experiencing a service disruption that is affecting the ability to log in and use the Monta app. Our team has identified the issue and is actively working to resolve it. We apologize for the inconvenience and will provide updates as soon as more information is available.
Posted Jun 20, 2026 - 08:24 UTC
This incident affects: General availability, Monta Charge - App, and Monta Hub - Web Portal.