Payment issue
Incident Report for Monta
Resolved
We haven't seen any further incidents regarding this.
Posted Sep 12, 2023 - 12:01 UTC
Monitoring
We have identified and resolved the issue and will be monitoring.
Posted Sep 12, 2023 - 09:36 UTC
Identified
We're investigating a problem with our payments. We've identified the problem and are rolling out a fix.
Posted Sep 12, 2023 - 09:21 UTC
This incident affected: Wallet.