Withdrawal Issue Update
Incident Report for Monta
Resolved
This incident has been resolved.
Posted Oct 03, 2024 - 10:13 UTC
Update
We are continuing to monitor for any further issues.
Posted Oct 03, 2024 - 09:27 UTC
Monitoring
From Friday afternoon to Monday mid-day, we experienced an issue where withdrawals were failing upon request. The problem has been resolved, and our team is actively working to approve the failed withdrawals.
Posted Sep 30, 2024 - 13:51 UTC
This incident affected: Wallet.