Support System downtime
Incident Report for Monta
Resolved
This incident has been resolved.
Posted Mar 15, 2023 - 08:25 UTC
Investigating
Our customer service messaging and emailing tool Intercom is currently experiencing a downtime.

This means that we are unable to reply to customer queries via chat & email at the moment.

Intercom is working on a fix, which can be followed here: https://www.intercomstatus.com/incidents/n43qp3qs3qyt

We are hoping for a quick solution and are sorry for the inconvenience and will get back to you as soon as the system is up and running again.

Thank you for understanding.
Posted Mar 14, 2023 - 09:44 UTC
This incident affected: Customer Service.