Customer Support slow or non-operative
Incident Report for Monta
Resolved
This incident has been resolved.
Posted Mar 22, 2023 - 19:34 UTC
Monitoring
We're back in action and everything works again.
Posted Mar 22, 2023 - 16:38 UTC
Investigating
Our software tool Intercom which we use for communication with customers via chat and email are currently having issues, meaning contacting our customer support via the app, email or web portal currently is not working or operating very slowly.

You can follow updates directly here on Intercom: https://www.intercomstatus.com/incidents/kk01chc3r4p5

We're hoping for a quick solution.
Posted Mar 22, 2023 - 16:23 UTC
This incident affected: Customer Service.