Delay in transactions from paid charges

Incident Report for Monta

Resolved

All transactions have been processed, and are being processed at normal speed.
Posted Apr 30, 2026 - 18:45 UTC

Investigating

Transactions from paid charges might be delayed and we're investigating.
Posted Apr 30, 2026 - 14:31 UTC
This incident affected: Wallet.