Virtual Solar Charging Speed Issue
Incident Report for Monta
Resolved
This incident has been resolved.
Posted May 29, 2024 - 13:44 UTC
Investigating
We have identified an issue affecting the speed of our Virtual Solar Charging service.

Our team is actively working to resolve this as quickly as possible.

We appreciate your patience and understanding and will provide updates as soon as the issue is resolved.
Posted May 28, 2024 - 11:03 UTC
This incident affected: Charging.