Some dashboards are unavailable

Incident Report for Monta

Resolved

This incident has been resolved.
Posted Jul 18, 2025 - 12:28 UTC

Investigating

One of our third party providers is experiencing an incident which is resulting in some dashboards being unavailable. We are actively monitoring the situation.

https://status.salesforce.com/incidents/10014427
Posted Jul 17, 2025 - 07:46 UTC
This incident affected: Monta Hub - Web Portal.