Load Management & Energy Management Portal Disruption

Incident Report for Monta

Resolved

Both the Load Management Portal and Energy Management Portal are now back to normal operation. We apologize for any inconvenience this may have caused.
Posted Jul 21, 2026 - 12:31 UTC

Update

We identified the problem, fixed it and all systems are nominal again
Posted Jul 21, 2026 - 12:31 UTC

Identified

We are currently investigating an issue causing the Load Management Portal and Energy Management Portal to be unavailable. Our team has identified the root cause and a rollback is actively in progress. We apologize for the inconvenience and will provide further updates as we work to restore full functionality.
Posted Jul 21, 2026 - 12:23 UTC
This incident affected: Monta Control.