Issues with Exports from the Hub
Incident Report for Monta
Resolved
This incident has been resolved.
Posted Oct 30, 2024 - 08:35 UTC
Investigating
We are seeing a high load on the data-export service, causing some requests to fail, and slow delivery of reports.
Posted Oct 29, 2024 - 16:40 UTC
This incident affected: Monta Hub - Web Portal.