Potential issue when paying in DKK for charges
Incident Report for Monta
Resolved
The matter has been resolved.
Posted Nov 04, 2024 - 11:24 UTC
Identified
We are currently a problem that may prevent customers from paying for charges in Danish Kroner (DKK).

We are looking into the matter and have a fix on the way.
Posted Nov 04, 2024 - 11:04 UTC
This incident affected: Wallet and Charging.