Customer Support - Emails not delivered
Incident Report for Monta
Resolved
Issue has been resolved.
Posted Sep 13, 2023 - 13:39 UTC
Identified
We have identified that as of recently (dating back to at least yesterday, Tuesday 12th) that our emails sent to customers contacting our support-team are not being delivered.

We have escalated this issue to our email system provider Zendesk and awaiting reply and a resolution.

As a workaround, please login to www.support.monta.com and review the statuses of your support tickets.

Live chat in our app remains unaffected.

Thank you for your patience and understanding while we diligently chase for a solution.

Best regards,

Michael
Head of Customer Support
Posted Sep 13, 2023 - 12:25 UTC
This incident affected: Customer Service.