Live Chat Unresponsive
Incident Report for Monta
Resolved
This incident has been resolved.
Posted Mar 13, 2024 - 16:34 UTC
Investigating
We are currently investigating an issue resulting in messages on live chats not shown or received.

We are working on a solution.

In the meantime, if you need support, please go to support.monta.com and create a support ticket.

Thank you and sorry for the inconvenience.
Posted Mar 13, 2024 - 14:55 UTC
This incident affected: Customer Service.