Issues accessing Monta Hub

Incident Report for Monta

Resolved

Resolved as duplicate
Posted Mar 11, 2026 - 14:57 UTC

Investigating

We are currently investigating reports of difficulties accessing Monta Hub. Some users may experience intermittent access issues or need to clear their browser cache to connect. Our team is actively working to resolve this issue.
Posted Mar 11, 2026 - 14:50 UTC
This incident affected: Monta Hub - Web Portal.