Payter transactions being rejected

Incident Report for Monta

Resolved

This incident has been resolved.
Posted Jul 17, 2026 - 16:52 UTC

Update

We are currently investigating an issue affecting payment transactions on select payment terminals. Some users may experience failed transactions when attempting to pay via card.
Posted Jul 17, 2026 - 11:40 UTC

Investigating

We are currently investigating this issue.
Posted Jul 17, 2026 - 11:40 UTC
This incident affected: Charging.