Monta Control is not loading

Incident Report for Monta

Resolved

Monta control is now back and loading as expected.
Posted Dec 08, 2025 - 13:47 UTC

Update

We are continuing to investigate this issue.
Posted Dec 08, 2025 - 13:46 UTC

Investigating

Monta Control is currently not loading and showing a blank page.

We are investigating the issue.
Posted Dec 08, 2025 - 13:32 UTC
This incident affected: Monta Control.