Customer Support - Delays
Incident Report for Monta
Resolved
This incident has been resolved.
Posted Jul 25, 2023 - 20:45 UTC
Update
We are continuing to investigate this issue.
Posted Jul 25, 2023 - 20:45 UTC
Update
Update:

Due to the high increase of customers and support inquiries at the moment, we have make the tough call to disable our "Request a Callback"-feature in the app.

We strive to always help our customers as well and efficiently as possible, and currently is the best way to help our customers are via chat and email.

We encourage everyone to visit our Help Center prior to contacting our support, as we have +400 articles covering all parts of our product, with full-length guides, including screenshots and best practices.

You can find the Help Center here: https://monta.com/uk/help-center/

We are doing everything we can to work as quickly as possible, but it is especially important for us that the quality is also high in every case.

Thank you very much for your understanding and your patience - we are so happy that we have such awesome customers.

Best Regards,

Michael
Head of Customer Support
Monta
Posted May 09, 2023 - 13:17 UTC
Investigating
We are experiencing an extraordinarily busy period in our support channels which can result in delays and long waiting times for both chat, email and phone.

We are working through the queues as fast as we can, and count on your patience and understanding in this busy period.

Thank you and please accept our apologies for potential delays or inconveniences.
Posted May 08, 2023 - 08:31 UTC
This incident affected: Customer Service.